Increased call failures to UK Mobiles
Incident Report for Jiminny
Resolved
We are no longer seeing call failures.
Posted Mar 17, 2020 - 15:29 UTC
Monitoring
Congestion across the majority of UK Mobile Operators caused call failures.
We've noticed a decrease in call failures but will continue to monitor the situation.
Posted Mar 17, 2020 - 12:12 UTC
Investigating
We are currently investigating this issue.
Posted Mar 17, 2020 - 11:03 UTC
This incident affected: Jiminny Voice (Outbound Dial).